Skip to main content
CVE-2026-24009VulnerabilityPublished

CVE-2026-24009: docling-core · Deserialization of Untrusted Data

Affects docling-coreSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.1 High : upgrade to 2.48.4 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.5% chance of exploitation in 30 days – higher than 74% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.48.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade docling-core to 2.48.4.

Affected software

ProductAffectedFixed in
docling-projectdocling-coreAffected
  • >=2.21.0 <2.48.4
Fixed in
  • 2.48.4
PyPIdocling-corepkg:pypi/docling-coreOther threatsAffected
  • <2.48.4 >=2.21.0
Fixed in
  • 2.48.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately assess their use of docling-core and PyYAML in document processing applications. The primary mitigation is to upgrade docling-core to version 2.48.4 or later, which replaces FullLoader with SafeLoader for YAML deserialization. If upgrading docling-core is not immediately feasible, organizations must ensure that PyYAML is upgraded to version 5.4 or higher, which defaults to SafeLoader and mitigates the vulnerability. Additionally, organizations should audit their applications to confirm that untrusted YAML input is not processed or is strictly validated and sanitized before deserialization. Implementing network-level controls to restrict access to services that accept YAML input can reduce exposure. Monitoring and logging deserialization activities may help detect anomalous or malicious payloads. Finally, organizations should maintain an up-to-date inventory of affected software components and apply security patches promptly to reduce the attack surface.

Description

Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.

References

Community reviews

Loading reviews…