CVE-2026-24504: Dell PowerProtect Data Domain · Improper Input Validation
Affects Dell PowerProtect Data DomainSource CVE Database V5
Not known to be exploited · CVSS 7.2 High · fixed in 8.6.1.10 : patch Dell PowerProtect Data Domain soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.6.1.10, 8.3.1.30 or later, 7.13.1.70 or later +1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Dell PowerProtect Data Domain to 8.6.1.10, 8.3.1.30 or later, 7.13.1.70 or later or 2.7.9 with DD OS 8.3.1.30.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DellPowerProtect Data Domain | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict remote access to the affected systems to trusted administrators only and monitor for unusual activity consistent with exploitation attempts.
Description
Dell PowerProtect Data Domain, versions 7.7.1.0 through 8.6, LTS2025 release version 8.3.1.0 through 8.3.1.20, LTS2024 release versions 7.13.1.0 through 7.13.1.60 contain an improper input validation vulnerability. A high privileged attacker with remote access could potentially exploit this vulnerability, leading to arbitrary command execution with root privileges.