Skip to main content
VulnerabilityPublished

CVE-2026-24784: dnnsoftware Dnn.Platform · Cross-site Scripting

Affects dnnsoftware Dnn.PlatformSource CVE Database V5

0

Not known to be exploited · CVSS 6.8 Medium : upgrade to 10.2.0 or 9.13.10 when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2.0, 9.13.10
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Dnn.Platform to 10.2.0 or 9.13.10; dnnsoftware/Dnn.Platform to 9.13.10.

Affected software

ProductAffectedFixed in
dnnsoftwareDnn.PlatformAffected
  • >=10.0.0 <10.2.0
Fixed in
  • 10.2.0
dnnsoftwareDnn.PlatformAffected
  • >=9.0.0 <9.13.10
Fixed in
  • 9.13.10
GitHubdnnsoftware/Dnn.Platformpkg:github/dnnsoftware/Dnn.PlatformOther threatsAffected
  • >=9.0.0 <9.13.10
  • =10.2.0
Fixed in
  • 9.13.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all Dnn.Platform instances to version 9.13.10 or later (including 10.2.0 or later) to apply the official fix. Until upgrades are completed, restrict module header and footer editing permissions strictly to trusted administrators and content editors with verified credentials. Implement robust access controls and monitor for unusual editing activity in these modules. Employ Content Security Policy (CSP) headers to limit the execution of unauthorized scripts on web pages. Conduct regular audits of CMS content, especially module headers and footers, to detect and remove any injected scripts. Enhance logging and alerting for changes to critical CMS components. Educate content editors about the risks of script injection and enforce strong authentication mechanisms, such as multifactor authentication, to reduce the risk of account compromise. Finally, integrate vulnerability scanning and penetration testing focused on CMS components to identify similar injection flaws proactively.

Description

CVE-2026-24784 is a cross-site scripting (XSS) vulnerability in the Dnn. Platform CMS affecting versions from 9.0.0 up to but not including 9.13.10 and 10.2.0. The flaw allows a content editor with module header/footer editing privileges to inject malicious scripts that execute in the browsers of other users. The vulnerability requires authenticated access with elevated privileges but does not require user interaction to trigger once the malicious content is loaded.

References

Community reviews

Loading reviews…