Skip to main content
VulnerabilityPublished

CVE-2026-24836: dnnsoftware Dnn.Platform · Cross-site Scripting

Affects dnnsoftware Dnn.PlatformSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 10.2.0 or 9.13.10 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2.0, 9.13.10
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade dnnsoftware Dnn.Platform to 10.2.0 or 9.13.10.

Affected software

ProductAffectedFixed in
dnnsoftwareDnn.PlatformAffected
  • >=10.0.0 <10.2.0
Fixed in
  • 10.2.0
dnnsoftwareDnn.PlatformAffected
  • >=9.0.0 <9.13.10
Fixed in
  • 9.13.10
GitHubdnnsoftware/Dnn.Platformpkg:github/dnnsoftware/Dnn.PlatformOther threatsAffected
  • 9.0.0 – 10.2.0
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade affected Dnn.Platform instances to version 9.13.10 or 10.2.0 or later, where the vulnerability is fixed. Until patching is complete, restrict extension installation and log note creation privileges to trusted administrators only, minimizing the risk of malicious script injection. Implement strict input validation and sanitization controls on any custom extensions or modules that interact with log notes. Monitor PersonaBar access logs and audit logs for unusual activity or unauthorized access attempts. Employ web application firewalls (WAFs) with rules designed to detect and block XSS payloads targeting the PersonaBar interface. Conduct regular security awareness training for administrators to recognize suspicious behavior and phishing attempts that could lead to credential compromise. Finally, maintain a robust incident response plan to quickly contain and remediate any exploitation attempts.

Description

CVE-2026-24836 is a high-severity cross-site scripting (XSS) vulnerability affecting Dnn. Platform versions from 9.0.0 up to but not including 9.13.10, and from 10.0.0 up to but not including 10.2.0.

References

Community reviews

Loading reviews…