Skip to main content
VulnerabilityPublished

CVE-2026-25054: n8n · Basic XSS

Affects n8nSource CVE Database V5

0

Not known to be exploited · CVSS 8.5 High : upgrade to 2.2.1 or 1.123.9 soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.1, 1.123.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade n8n and n8n-io/n8n to 2.2.1 or 1.123.9.

Affected software

ProductAffectedFixed in
n8n-ion8nAffected
  • <2.2.1
Fixed in
  • 2.2.1
n8n-ion8nAffected
  • <1.123.9
Fixed in
  • 1.123.9
GitHubn8n-io/n8npkg:github/n8n-io/n8nOther threatsAffected
  • <1.123.9
  • <2.2.1
Fixed in
  • 1.123.9
  • 2.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all n8n instances to version 1.123.9 or 2.2.1 or later to remediate this vulnerability. Beyond patching, organizations should enforce strict access controls limiting workflow creation and modification permissions to trusted users only, minimizing the attack surface. Implement multi-factor authentication (MFA) to reduce the risk of credential compromise. Regularly audit workflows for suspicious or unexpected markdown content, especially in shared environments. Employ Content Security Policy (CSP) headers to restrict script execution origins and reduce the impact of potential XSS attacks. Monitor logs for unusual user activity related to workflow modifications. Educate users about the risks of interacting with untrusted workflows and encourage reporting of suspicious behavior. Finally, consider isolating n8n instances within segmented network zones to limit lateral movement in case of compromise.

Description

CVE-2026-25054 is a high-severity Cross-Site Scripting (XSS) vulnerability in the n8n open source workflow automation platform, affecting versions prior to 1.123.9 and 2.2.1. The flaw exists in a markdown rendering component used in the user interface, including workflow sticky notes and other markdown-supported areas. An authenticated user with workflow creation or modification permissions can inject malicious scripts that execute with same-origin privileges when other users view the crafted workflows. This can lead to session hijacking and account takeover. The vulnerability requires authentication and some user interaction but does not require elevated privileges beyond workflow modification rights. No known exploits are currently reported in the wild.

References

Community reviews

Loading reviews…