CVE-2026-25128: NaturalIntelligence fast-xml-parser · Improper Input Validation
Affects NaturalIntelligence fast-xml-parserSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 5.3.4 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.3.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade NaturalIntelligence fast-xml-parser to 5.3.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| NaturalIntelligencefast-xml-parser | Affected
| Fixed in– |
npmfast-xml-parserpkg:npm/fast-xml-parserOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately identify all instances of fast-xml-parser versions 5.0.9 through 5.3.3 in their software environments, including direct dependencies and transitive dependencies in their JavaScript projects. The primary mitigation is to upgrade to version 5.3.4 or later, where the vulnerability is fixed. For environments where immediate upgrade is not feasible, implement input validation and sanitization at the application boundary to reject XML inputs containing out-of-range numeric entities. Employ runtime exception handling to gracefully manage parser errors and prevent application crashes. Additionally, deploy Web Application Firewalls (WAFs) or XML gateways configured to detect and block malformed XML payloads. Monitor application logs for unexpected parser exceptions and crashes to detect potential exploitation attempts. Incorporate this vulnerability into vulnerability management and patching workflows to ensure timely updates. Finally, conduct security testing on XML processing components to verify resilience against malformed inputs.
Description
fast-xml-parser allows users to validate XML, parse XML to JS object, or build XML from JS object without C/C++ based libraries and no callback. In versions 5.0.9 through 5.3.3, a RangeError vulnerability exists in the numeric entity processing of fast-xml-parser when parsing XML with out-of-range entity code points (e.g., `�` or `�`). This causes the parser to throw an uncaught exception, crashing any application that processes untrusted XML input. Version 5.3.4 fixes the issue.
References
- github.com/NaturalIntelligence/fast-xml-parser/security/advisories/GHSA-37qj-frw5-hhjh (opens in a new tab)
- github.com/NaturalIntelligence/fast-xml-parser/commit/4e387f61c4a5cef792f6a2f42467013290bf95dc (opens in a new tab)
- github.com/NaturalIntelligence/fast-xml-parser/releases/tag/v5.3.4 (opens in a new tab)