CVE-2026-25233: pear pearweb · Operator Precedence Logic Error
Affects pear pearwebSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 1.33.0 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.33.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade pearweb and pear/pearweb to 1.33.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pearpearweb | Affected
| Fixed in
|
GitHubpear/pearwebpkg:github/pear/pearwebOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The primary mitigation is to upgrade pearweb installations to version 1.33.0 or later, where the logic bug has been corrected. Organizations should implement strict role-based access controls and audit maintainer permissions regularly to ensure only authorized lead maintainers have roadmap modification rights. Conduct code reviews and testing to verify that operator precedence and conditional logic in custom or forked versions of pearweb are correctly implemented. Employ monitoring and alerting on roadmap changes to detect unauthorized modifications promptly. Where possible, isolate development and project management environments to reduce exposure. Educate development teams on the importance of applying security patches promptly and maintaining least privilege principles. For organizations unable to upgrade immediately, consider implementing compensating controls such as manual approval workflows for roadmap changes or temporarily restricting maintainer roles. Finally, maintain an incident response plan to address potential exploitation scenarios involving project management data integrity.
Description
CVE-2026-25233 is a high-severity logic vulnerability in the PEAR pearweb system affecting versions prior to 1.33.0. The flaw is an operator precedence logic error in the roadmap role check, which allows non-lead maintainers to create, update, or delete roadmaps without proper authorization. This vulnerability does not require user interaction or elevated privileges beyond maintainer access and can be exploited remotely over the network. Although no known exploits are currently in the wild, the issue impacts the integrity of project management data within pearweb. The vulnerability has been patched in version 1.33.0, and organizations using affected versions should upgrade promptly. European organizations relying on PEAR components for PHP development or project management are at risk, especially those with active development teams using pearweb.