Skip to main content
VulnerabilityPublished

CVE-2026-25482: craftcms commerce · Cross-site Scripting

Affects craftcms commerceSource CVE Database V5

0

Not known to be exploited · CVSS 6.2 Medium : upgrade to 5.5.2 or 4.10.1 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.2, 4.10.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade commerce to 5.5.2 or 4.10.1; craftcms/commerce to 5.5.2.

Affected software

ProductAffectedFixed in
craftcmscommerceAffected
  • >=5.0.0 <5.5.2
Fixed in
  • 5.5.2
craftcmscommerceAffected
  • >=4.0.0-RC1 <4.10.1
Fixed in
  • 4.10.1
GitHubcraftcms/commercepkg:github/craftcms/commerceOther threatsAffected
  • >=5.0.0 <5.5.2
Fixed in
  • 5.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade Craft Commerce installations to versions 4.10.1 or 5.5.2 or later to apply the official patch. Until patched, restrict admin dashboard access to trusted personnel and enforce strong multi-factor authentication to reduce the risk of credential compromise. Implement Content Security Policy (CSP) headers to limit the impact of injected scripts. Conduct regular audits of order status inputs to detect suspicious or malformed entries that could indicate attempted exploitation. Educate administrators about phishing and social engineering risks that could lead to credential theft. Monitor web server and application logs for unusual activity around the dashboard widget. Consider isolating the admin dashboard behind VPN or IP allowlists to reduce exposure. Finally, review and harden JavaScript rendering practices in custom plugins or extensions to prevent similar injection flaws.

Description

CVE-2026-25482 is a stored DOM-based Cross-Site Scripting (XSS) vulnerability affecting Craft Commerce versions 4.0.0-RC1 to 4.10.0 and 5.0.0 to 5.5.1. The vulnerability arises from improper escaping of the Order Status Name in the "Recent Orders" dashboard widget, which is rendered via JavaScript string concatenation.

References

Community reviews

Loading reviews…