CVE-2026-25489: craftcms commerce · Cross-site Scripting
Affects craftcms commerceSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.5.2 or 4.10.1 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.5.2, 4.10.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade commerce to 5.5.2 or 4.10.1; craftcms/commerce to 5.5.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscommerce | Affected
| Fixed in
|
GitHubcraftcms/commercepkg:github/craftcms/commerceOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade Craft Commerce installations to versions 4.10.1 or later in the 4.x series, or 5.5.2 or later in the 5.x series, where the vulnerability is patched. Additionally, administrators should audit Tax Zone entries for suspicious or unexpected content and sanitize existing data if possible. Implement strict role-based access controls to limit the number of users with administrative privileges and enforce multi-factor authentication to reduce the risk of compromised admin accounts. Employ Content Security Policy (CSP) headers to mitigate the impact of potential XSS by restricting script execution sources. Regularly monitor admin panel activity logs for unusual behavior indicative of exploitation attempts. Finally, conduct security awareness training to ensure administrators recognize phishing or social engineering attempts that might lead to viewing malicious inputs.
Description
Craft Commerce is an ecommerce platform for Craft CMS. In versions from 4.0.0-RC1 to 4.10.0 and from 5.0.0 to 5.5.1, a stored XSS vulnerability in Craft Commerce allows attackers to execute malicious JavaScript in an administrator’s browser. This occurs because the Name & Description fields in Tax Zones are not properly sanitized before being displayed in the admin panel. This issue has been patched in versions 4.10.1 and 5.5.2.
References
- github.com/craftcms/commerce/security/advisories/GHSA-v585-mf6r-rqrc (opens in a new tab)
- github.com/craftcms/commerce/commit/fa273330807807d05b564d37c88654cd772839ee (opens in a new tab)
- github.com/craftcms/commerce/releases/tag/4.10.1 (opens in a new tab)
- github.com/craftcms/commerce/releases/tag/5.5.2 (opens in a new tab)