Skip to main content
CVE-2026-25509VulnerabilityPublished

CVE-2026-25509: ci4-cms-erp ci4ms · Observable Response Discrepancy

Affects ci4-cms-erp ci4msSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.28.5.0 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.28.5.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade ci4ms and ci4-cms-erp/ci4ms to 0.28.5.0.

Affected software

ProductAffectedFixed in
ci4-cms-erpci4msAffected
  • <0.28.5.0
Fixed in
  • 0.28.5.0
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threatsAffected
  • <0.28.5.0
Fixed in
  • 0.28.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations using ci4ms should immediately upgrade to version 0.28.5.0 or later, where the vulnerability is patched. If upgrading is not immediately feasible, implement application-layer mitigations such as uniform response messages and timing controls during password reset requests to eliminate observable discrepancies. Employ rate limiting and CAPTCHA challenges on password reset endpoints to hinder automated enumeration attempts. Monitor logs for abnormal password reset request patterns that may indicate enumeration activity. Additionally, educate users about phishing risks and encourage strong, unique passwords combined with multi-factor authentication (MFA) to reduce the impact of potential account enumeration. Regularly audit and update CMS components and dependencies to ensure timely application of security patches. Finally, consider implementing Web Application Firewalls (WAFs) with rules designed to detect and block enumeration behaviors specific to ci4ms password reset flows.

Description

CVE-2026-25509 is a medium severity vulnerability in the ci4ms CMS based on CodeIgniter 4, allowing unauthenticated attackers to enumerate registered email addresses via observable response discrepancies during the password reset process. This email enumeration flaw can aid attackers in identifying valid user accounts, facilitating targeted phishing or brute-force attacks. The vulnerability affects ci4ms versions prior to 0.28.5.0 and has been patched in that release. Exploitation requires no authentication or user interaction and can be performed remotely over the network. While it does not directly impact system integrity or availability, the confidentiality of user registration data is compromised. European organizations using ci4ms should upgrade promptly to mitigate this risk. Countries with higher adoption of CodeIgniter-based CMS solutions and significant enterprise or government use of ci4ms are more likely to be affected.

References

Community reviews

Loading reviews…