Skip to main content
CVE-2026-25514VulnerabilityPublished

CVE-2026-25514: NeoRazorX facturascripts · Improper Input Validation

Affects NeoRazorX facturascriptsSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 2025.81 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2025.81
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade facturascripts and neorazorx/facturascripts to 2025.81.

Affected software

ProductAffectedFixed in
NeoRazorXfacturascriptsAffected
  • <2025.81
Fixed in
  • 2025.81
GitHubneorazorx/facturascriptspkg:github/neorazorx/facturascriptsOther threatsAffected
  • <2025.81
Fixed in
  • 2025.81

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade FacturaScripts to version 2025.81 or later to apply the official patch. In addition, implement multi-factor authentication (MFA) to reduce the risk of credential compromise. Conduct thorough audits of user access rights to limit authenticated users to necessary privileges only. Employ Web Application Firewalls (WAFs) with SQL injection detection rules tailored to FacturaScripts’ query patterns to provide an additional layer of defense. Review and harden database permissions to restrict the scope of potential SQL injection impacts. Regularly monitor logs for unusual query patterns or data access anomalies indicative of exploitation attempts. Educate users about credential security and monitor for compromised accounts. Finally, consider deploying runtime application self-protection (RASP) solutions that can detect and block injection attacks in real time.

Description

CVE-2026-25514 is a critical SQL injection vulnerability in FacturaScripts versions prior to 2025.81, affecting the autocomplete functionality. It allows authenticated attackers to execute arbitrary SQL queries by exploiting improper input validation in the CodeModel::all() method, leading to potential extraction of sensitive data such as user credentials, configuration settings, and business data. The vulnerability requires authentication but no user interaction and has a high CVSS score of 8.7. Although no known exploits are reported in the wild yet, the impact on confidentiality, integrity, and availability is significant. The issue has been patched in version 2025.81. European organizations using FacturaScripts should prioritize updating to the patched version and implement strict input validation and database query parameterization to mitigate risks. Countries with higher adoption of FacturaScripts and significant SME sectors relying on ERP/accounting software are more likely to be affected.

References

Community reviews

Loading reviews…