CVE-2026-25640: pydantic-ai · Path Traversal
Affects pydantic-aiSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 1.51.0 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.51.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade pydantic-ai to 1.51.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pydanticpydantic-ai | Affected
| Fixed in
|
PyPIpydantic-aipkg:pypi/pydantic-aiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official fix is available in pydantic-ai version 1.51.0. Users and administrators should upgrade affected installations to version 1.51.0 or later to remediate this vulnerability. No other vendor mitigation guidance or temporary fixes are indicated. Patch status is confirmed by the vendor advisory.
Description
Pydantic AI is a Python agent framework for building applications and workflows with Generative AI. From 1.34.0 to before 1.51.0, a path traversal vulnerability in the Pydantic AI web UI allows an attacker to serve arbitrary JavaScript in the context of the application by crafting a malicious URL. In affected versions, the CDN URL is constructed using a version query parameter from the request URL. This parameter is not validated, allowing path traversal sequences that cause the server to fetch and serve attacker-controlled HTML/JavaScript from an arbitrary source on the same CDN, instead of the legitimate chat UI package. If a victim clicks the link or visits it via an iframe, attacker-controlled code executes in their browser, enabling theft of chat history and other client-side data. This vulnerability only affects applications that use Agent.to_web to serve a chat interface and clai web to serve a chat interface from the CLI. These are typically run locally (on localhost), but may also be deployed on a remote server. This vulnerability is fixed in 1.51.0.
References
- github.com/pydantic/pydantic-ai/security/advisories/GHSA-wjp5-868j-wqv7 (opens in a new tab)
- github.com/pydantic/pydantic-ai/releases/tag/v1.51.0 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-25640 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2437753 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-25640.json (opens in a new tab)