Skip to main content
CVE-2026-25892VulnerabilityPublished

CVE-2026-25892: vrana adminer · Improper Input Validation

Affects vrana adminerSource CVE Database V5

0

Not known to be exploited · public detection template (Nuclei) · CVSS 7.5 High : upgrade to 5.4.2 soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.7% chance of exploitation in 30 days – higher than 77% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Feb 2026

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade vrana adminer to 5.4.2.

Affected software

ProductAffectedFixed in
vranaadminerAffected
  • >=4.6.2 <5.4.2
Fixed in
  • 5.4.2

AI-suggested

1. Immediate upgrade to Adminer version 5.4.2 or later, which contains the patch for this vulnerability. 2. If upgrading is not immediately possible, implement network-level controls such as web application firewalls (WAFs) to restrict access to the ?script=version endpoint, allowing only trusted origins or IP addresses. 3. Monitor web server logs for unusual POST requests to the ?script=version endpoint, particularly those containing the version[] parameter, to detect potential exploitation attempts. 4. Employ strict Content Security Policy (CSP) headers and CORS policies to limit cross-origin requests to Adminer interfaces. 5. Isolate Adminer instances behind VPNs or internal networks to reduce exposure to external attackers. 6. Regularly audit and update all database management tools and related software to ensure timely application of security patches. 7. Educate IT and security teams about this specific vulnerability and the importance of validating input origins in web applications.

Description

CVE-2026-25892 is a high-severity vulnerability in Adminer versions 4.6.2 up to 5.4.1, caused by improper input validation in the version check mechanism. The vulnerability arises because the ? script=version endpoint accepts POST requests from any origin without validating the source, allowing an attacker to send a crafted version[] parameter. This parameter is converted by PHP into an array instead of a string, causing openssl_verify() to throw a TypeError and resulting in an HTTP 500 error that disrupts service for all users. No authentication or user interaction is required to exploit this remotely over the network. The impact is a denial-of-service condition affecting availability.

References

Community reviews

Loading reviews…