CVE-2026-25918: RageAgainstThePixel unity-cli · Sensitive Data in Logs
Affects RageAgainstThePixel unity-cliSource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 1.8.2 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.2
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade RageAgainstThePixel unity-cli to 1.8.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RageAgainstThePixelunity-cli | Affected
| Fixed in
|
AI-suggested
European organizations should immediately upgrade unity-cli to version 1.8.2 or later to ensure the vulnerability is patched. Until the upgrade is applied, avoid using the --verbose flag with the sign-package command, especially in production or CI/CD environments. Review and sanitize existing logs to remove any sensitive credentials that may have been recorded. Implement strict access controls on log files and CI/CD systems to limit exposure. Additionally, consider using environment variables or secure vaults for credential management instead of passing sensitive data via command-line arguments. Conduct regular audits of logging practices to ensure sensitive information is not inadvertently exposed. Educate developers and DevOps teams about the risks of verbose logging and secure handling of credentials. Finally, monitor for any unauthorized access attempts that could indicate exploitation of leaked credentials.
Description
CVE-2026-25918 is a medium severity vulnerability in the RageAgainstThePixel unity-cli tool prior to version 1.8.2. The sign-package command logs sensitive credentials such as email and password in plaintext when the --verbose flag is used. These credentials are output via JSON.stringify without sanitization, exposing secrets to shell history, CI/CD logs, and log aggregation systems. Exploitation requires local access and the use of the verbose flag, with no user interaction needed. The vulnerability risks credential leakage, potentially leading to unauthorized access or further compromise. It is fixed in version 1.8.