Skip to main content
CVE-2026-25931VulnerabilityPublished

CVE-2026-25931: streetsidesoftware vscode-spell-checker · Incorrect Default Permissions

Affects streetsidesoftware vscode-spell-checkerSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade to 4.5.4 soon.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.4
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade streetsidesoftware vscode-spell-checker to 4.5.4.

Affected software

ProductAffectedFixed in
streetsidesoftwarevscode-spell-checkerAffected
  • <4.5.4
Fixed in
  • 4.5.4

AI-suggested

European organizations should immediately update the vscode-spell-checker extension to version 4.5.4 or later to ensure the vulnerability is patched. Additionally, enforce strict workspace trust policies in Visual Studio Code to prevent automatic execution of code from untrusted workspaces. Educate developers about the risks of opening workspaces from unverified sources and implement endpoint security controls to monitor and restrict execution of unauthorized scripts. Employ application whitelisting and behavior-based detection to identify suspicious extension host activities. Integrate code signing and verification for workspace configuration files where possible. Regularly audit installed extensions and their versions across developer environments. Consider isolating development environments using containerization or virtual machines to limit the impact of potential code execution. Finally, monitor security advisories for any emerging exploits targeting this vulnerability and respond promptly.

Description

CVE-2026-25931 is a high-severity vulnerability in the vscode-spell-checker extension for Visual Studio Code versions prior to 4.5.4. It arises from incorrect default permissions where the extension trusts the cSpell.trustedWorkspace configuration flag by default, allowing untrusted workspaces to execute malicious JavaScript/TypeScript configuration files. This leads to arbitrary code execution with the user's privileges when opening a malicious workspace. The vulnerability does not require prior authentication but does require user interaction to open the workspace. It impacts confidentiality, integrity, and availability by enabling attacker-controlled code execution. The issue is fixed in version 4.5.

References

Community reviews

Loading reviews…