Skip to main content
VulnerabilityPublished

CVE-2026-26274: octobercms october · Incomplete List of Disallowed Inputs

Affects octobercms octoberSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.6 Medium : upgrade to 4.1.10 or 3.7.14 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.10, 3.7.14
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade october to 4.1.10 or 3.7.14; octobercms/october to 3.7.14.

Affected software

ProductAffectedFixed in
octobercmsoctoberAffected
  • >=4.0.0 <4.1.10
Fixed in
  • 4.1.10
octobercmsoctoberAffected
  • <3.7.14
Fixed in
  • 3.7.14
GitHuboctobercms/octoberpkg:github/octobercms/octoberOther threatsAffected
  • <3.7.14
Fixed in
  • 3.7.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in October CMS versions 3.7.14 and 4.1.10. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated in the advisory.

Description

October is a Content Management System (CMS) and web platform. Prior to 3.7.14 and 4.1.10, a vulnerability was identified in the Twig sandbox security policy that allowed database write operations when cms.safe_mode is enabled. Backend users with Developer permissions could use Twig template markup to execute insert, update, and delete operations on any database table through the query builder, which is included in the sandbox allow-list. This vulnerability is fixed in 3.7.14 and 4.1.10.

References

Community reviews

Loading reviews…