CVE-2026-27197: getsentry sentry · Improper Authentication
Affects getsentry sentrySource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 26.2.0 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 26.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade getsentry sentry to 26.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| getsentrysentry | Affected
| Fixed in
|
AI-suggested
To mitigate CVE-2026-27197, organizations should immediately upgrade all affected Sentry instances to version 26.2.0 or later, where the vulnerability is patched. For environments where immediate upgrading is not feasible, enforcing user account-based two-factor authentication (2FA) is a critical interim control to prevent attackers from completing authentication even if they can forge SAML assertions. It is important to communicate to users that 2FA must be enabled individually, as administrators cannot enforce it on their behalf. Additionally, organizations should audit their Sentry configurations to ensure that multi-organization setups are strictly necessary and consider consolidating or isolating organizations to reduce attack surface. Restrict permissions to modify SSO settings to trusted administrators only and monitor for unusual SSO configuration changes. Regularly review SAML Identity Providers configured and remove any untrusted or unused IdPs. Implement network segmentation and monitoring around Sentry instances to detect anomalous authentication attempts. Finally, maintain up-to-date incident response plans that include procedures for SSO compromise scenarios.
Description
Sentry is a developer-first error tracking and performance monitoring tool. Versions 21.12.0 through 26.1.0 have a critical vulnerability in its SAML SSO implementation which allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. Self-hosted users are only at risk if the following criteria is met: ore than one organizations are configured (SENTRY_SINGLE_ORGANIZATION = True), or malicious user has existing access and permissions to modify SSO settings for another organization in a multo-organization instance. This issue has been fixed in version 26.2.0. To workaround this issue, implement user account-based two-factor authentication to prevent an attacker from being able to complete authentication with a victim's user account. Organization administrators cannot do this on a user's behalf, this requires individual users to ensure 2FA has been enabled for their account.