CVE-2026-28292: steveukx simple-git · OS Command Injection
Affects steveukx simple-gitSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.32.3 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.3% chance of exploitation in 30 days – higher than 71% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.32.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade steveukx simple-git to 3.32.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| steveukxsimple-git | Affected
| Fixed in
|
npmsimple-gitpkg:npm/simple-gitOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade simple-git to a version later than 3.32.2, preferably at least 3.33.0 or later, as version 3.23.0 contains an updated fix and later versions should include the patch. Since the vendor advisory does not explicitly state patch availability beyond the fixed version, users should verify the latest patched version from the official simple-git repository or vendor advisories. No other mitigation or workaround is provided. Patch status is confirmed by the presence of a fixed version (3.23.0) in the description.
Description
`simple-git`, an interface for running git commands in any node.js application, has an issue in versions 3.15.0 through 3.32.2 that allows an attacker to bypass two prior CVE fixes (CVE-2022-25860 and CVE-2022-25912) and achieve full remote code execution on the host machine. Version 3.23.0 contains an updated fix for the vulnerability.
References
- github.com/steveukx/git-js/security/advisories/GHSA-r275-fr43-pm7q (opens in a new tab)
- github.com/steveukx/git-js/commit/f7042088aa2dac59e3c49a84d7a2f4b26048a257 (opens in a new tab)
- codeant.ai/security-research/security-research-simple-git-remote-code-execution-cve-2026-28292 (opens in a new tab)
- codeant.ai/security-research/simple-git-remote-code-execution-cve-2026-28292 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-28292 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2446162 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-28292.json (opens in a new tab)