CVE-2026-28356: defnull multipart · ReDoS
Affects defnull multipartSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.3.1 or 1.2.2 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.3.1, 1.2.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade multipart to 1.3.1 or 1.2.2; multipart to 1.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| defnullmultipart | Affected
| Fixed in
|
| defnullmultipart | Affected
| Fixed in
|
PyPImultipartpkg:pypi/multipartOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in multipart versions 1.2.2, 1.3.1, and 1.4.0-dev. Users and administrators should upgrade to one of these fixed versions to remediate the vulnerability. There are no vendor advisories indicating that no action is required or that the issue is already mitigated by other means. Therefore, upgrading the multipart library to a fixed version is the recommended mitigation.
Description
## Summary The `parse_options_header()` function in `multipart.py` uses a regular expression with an *ambiguous alternation*, which can cause *exponential backtracking (ReDoS)* when parsing maliciously crafted HTTP or multipart segment headers. This can be abused for **denial of service (DoS)** attacks against web applications using this library to parse request headers or `multipart/form-data` streams. ## Impact Any WSGI or ASGI application using `multipart.parse_form_data()` directly or indirectly (e.g. while parsing `multipart/form-data` streams) is vulnerable. The slow-down is significant enough to block request handling threads for multiple seconds per request. ## Affected versions All versions up to and including `1.3.0` are affected. The issue is fixed in `1.2.2`, `1.3.1` and `1.4.0-dev`.
References
- github.com/defnull/multipart/security/advisories/GHSA-p2m9-wcp5-6qw3 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-28356 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2447059 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-28356.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:6761 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:5809 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:6762 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:10184 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:42644 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:37275 (opens in a new tab)