CVE-2026-28384: Canonical lxd · OS Command Injection
Affects Canonical lxdSource CVE Database V5
Not known to be exploited · CVSS 9.4 Critical · fixed in 6.7 : patch Canonical lxd as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.7, 5.21.4, 5.0.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Canonical lxd to 6.7, 5.21.4 or 5.0.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Canonicallxd | Affected
| Fixed in
|
GitHubcanonical/lxdpkg:github/canonical/lxdOther threats | Affected
| Fixed in– |
GitHublxdpkg:github/lxdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-28384, organizations should immediately upgrade affected LXD installations to the patched versions provided by Canonical: snap versions 5.0.6-e49d9f4 (5.0/stable), 5.21.4-1374f39 (5.21/stable), or 6.7-1f11451 (6.0 stable). If you cannot patch yet, restrict access to the LXD API endpoints, especially image and backup interfaces, to trusted and authenticated users only. Implement strict network segmentation and firewall rules to limit exposure of the LXD API to internal networks or management VLANs. Employ strong authentication mechanisms and monitor API usage for unusual or unauthorized commands. Additionally, review and harden container host configurations to minimize daemon privileges and isolate container workloads. Regularly audit container and host logs for signs of exploitation attempts. Consider deploying runtime security tools that can detect anomalous command execution within container environments. Finally, maintain an up-to-date inventory of LXD versions in use to ensure timely patch management.
Description
CVE-2026-28384 is a critical OS command injection vulnerability in Canonical's LXD container management system affecting versions 4.12 through 6.6. It arises from improper sanitization of the compression_algorithm parameter in API calls related to image and backup endpoints. An authenticated but unprivileged user can exploit this flaw to execute arbitrary commands with the privileges of the LXD daemon, potentially leading to full system compromise. The vulnerability requires no user interaction and has a CVSS 4.0 score of 9.4, reflecting its high impact on confidentiality, integrity, and availability. Fixed versions are available in specific snap channels starting from 5.0.
References
- github.com/canonical/lxd/security/advisories/GHSA-4rmf-rcp8-2r9g (opens in a new tab)
- github.com/canonical/lxd/commit/043696a13171ace7dd4c2b32d34ce039ab629052 (opens in a new tab)
- github.com/canonical/lxd/commit/7046979645c2ce1b63b2f9e60ddf6cbc4c4b78f9 (opens in a new tab)
- github.com/canonical/lxd/commit/b7b411caf5c4971bfe2386c72128f44d7e2aaf4f (opens in a new tab)
- discourse.ubuntu.com/t/lxd-authenticated-remote-code-execution-fixes-available/78365 (opens in a new tab)