Skip to main content
VulnerabilityPublished Updated

CVE-2026-28425: statamic cms · Code Injection

Affects statamic cmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.0 High : upgrade to 6.7.2 or 5.73.16 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.7.2, 5.73.16
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade cms to 6.7.2 or 5.73.16; statamic/cms to 5.73.16.

Affected software

ProductAffectedFixed in
statamiccmsAffected
  • >=6.0.0 <6.7.2
Fixed in
  • 6.7.2
statamiccmsAffected
  • <5.73.16
Fixed in
  • 5.73.16
GitHubstatamic/cmspkg:github/statamic/cmsOther threatsAffected
  • <5.73.16
Fixed in
  • 5.73.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Immediately upgrade Statamic CMS to version 5.73.16 or 6.7.2 or later to apply the official patch addressing this vulnerability.
  2. Review and restrict control panel user permissions to the minimum necessary, especially permissions related to configuring fields, editing entries, and configuring forms.
  3. Audit all third-party addons for use of Antlers-enabled fields and ensure they are compatible with patched Statamic versions.
  4. Implement strong authentication mechanisms such as multi-factor authentication (MFA) for control panel users to reduce the risk of account compromise.
  5. Monitor logs for unusual activity related to control panel access and Antlers template usage.
  6. Conduct regular security reviews and penetration testing focusing on CMS user roles and template injection risks.
  7. Educate administrators and developers about the risks of code injection via templating engines and enforce secure coding practices when extending CMS functionality.
  8. If immediate patching is not possible, consider disabling Antlers execution on user-controlled inputs where feasible as a temporary mitigation.

Description

Statmatic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.16 and 6.7.2, an authenticated control panel user with access to Antlers-enabled inputs may be able to achieve remote code execution in the application context. That can lead to full compromise of the application, including access to sensitive configuration, modification or exfiltration of data, and potential impact on availability. Exploitation is only possible where Antlers runs on user-controlled content—for example, content fields with Antlers explicitly enabled (requiring permission to configure fields and to edit entries), built-in config that supports Antlers such as Forms email notification settings (requiring configuration permission), or third-party addons that add Antlers-enabled fields to entries (for example, the SEO Pro addon). In each case the attacker must have the relevant control panel permissions. This has been fixed in 5.73.16 and 6.7.2. Users of addons that depend on Statamic should ensure that after updating they are running a patched Statamic version.

References

Community reviews

Loading reviews…