Skip to main content
VulnerabilityPublished Updated

CVE-2026-29091: locutusjs locutus · Eval Injection

Affects locutusjs locutusSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 3.0.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade locutus and locutusjs/locutus to 3.0.0.

Affected software

ProductAffectedFixed in
locutusjslocutusAffected
  • <3.0.0
Fixed in
  • 3.0.0
npmlocutusjs/locutuspkg:npm/locutusjs/locutusOther threatsAffected
  • <3.0.0
Fixed in
  • 3.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official fix is available in locutus version 3.0.0. Users and administrators should upgrade to version 3.0.0 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

Locutus brings stdlibs of other programming languages to JavaScript for educational purposes. Prior to version 3.0.0, a remote code execution (RCE) flaw was discovered in the locutus project, specifically within the call_user_func_array function implementation. The vulnerability allows an attacker to inject arbitrary JavaScript code into the application's runtime environment. This issue stems from an insecure implementation of the call_user_func_array function (and its wrapper call_user_func), which fails to properly validate all components of a callback array before passing them to eval(). This issue has been patched in version 3.0.0.

References

Community reviews

Loading reviews…