Skip to main content
VulnerabilityPublished

CVE-2026-29176: craftcms commerce · Cross-site Scripting

Affects craftcms commerceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 5.5.3 or 4.10.2 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.5.3, 4.10.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade commerce and craftcms/commerce to 5.5.3 or 4.10.2.

Affected software

ProductAffectedFixed in
craftcmscommerceAffected
  • >=5.0.0 <5.5.3
Fixed in
  • 5.5.3
craftcmscommerceAffected
  • >=4.0.0 <4.10.2
Fixed in
  • 4.10.2
GitHubcraftcms/commercepkg:github/craftcms/commerceOther threatsAffected
  • <4.10.2
  • >=4.0.0
  • <5.5.3
  • >=5.0.0
Fixed in
  • 4.10.2
  • 5.5.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should upgrade Craft Commerce to version 5.5.3 or later, where the vulnerability is patched with proper HTML escaping. Until an upgrade is possible, administrators should restrict product editing permissions to trusted users only and monitor for suspicious activity on the Inventory Locations page. Implementing Content Security Policy (CSP) headers can help mitigate the impact of injected scripts by restricting script execution sources. Regularly auditing user permissions and employing multi-factor authentication (MFA) for administrative accounts can reduce the risk of compromised credentials being used to exploit this vulnerability. Additionally, security teams should review logs for unusual behavior around variant product edits and consider deploying web application firewalls (WAFs) with rules targeting XSS payloads. Educating administrators about the risk of executing untrusted input and encouraging cautious handling of product data can further reduce exploitation chances.

Description

Craft Commerce is an ecommerce platform for Craft CMS. Prior to 5.5.3, A stored XSS vulnerability exists in the Commerce Settings - Inventory Locations page. The Name field is rendered without proper HTML escaping, allowing an attacker to execute arbitrary JavaScript. This XSS triggers when an administrator (or user with product editing permissions) creates or edits a variant product. This vulnerability is fixed in 5.5.3.

References

Community reviews

Loading reviews…