CVE-2026-29177: craftcms commerce · Cross-site Scripting
Affects craftcms commerceSource CVE Database V5
Public exploit available · CVSS 1.9 Low : upgrade to 5.5.3 or 4.10.2 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.5.3, 4.10.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 10 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade commerce and craftcms/commerce to 5.5.3 or 4.10.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscommerce | Affected
| Fixed in
|
| craftcmscommerce | Affected
| Fixed in
|
GitHubcraftcms/commercepkg:github/craftcms/commerceOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately upgrade Craft Commerce to versions 4.10.2 or 5.5.3 or later, where the vulnerability is patched. Until upgrades are applied, administrators should restrict access to the order details interface to trusted users only and monitor for suspicious activity. Implementing Content Security Policy (CSP) headers can help mitigate the impact of injected scripts by restricting script execution sources. Input validation and output encoding should be reviewed and enhanced in custom plugins or integrations interacting with order data. Regular security audits and penetration testing focused on user input handling in ecommerce workflows are recommended. Additionally, educating users about the risks of interacting with untrusted content and monitoring logs for unusual order detail access patterns can reduce exploitation likelihood.
Description
Craft Commerce is an ecommerce platform for Craft CMS. Prior to 4.10.2 and 5.5.3, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Craft Commerce Order details. Malicious JavaScript can be injected via the Shipping Method Name, Order Reference, or Site Name. When a user opens the order details slideout via a double-click on the order index page, the injected payload executes. This vulnerability is fixed in 4.10.2 and 5.5.3.