Skip to main content
VulnerabilityPublished Updated

CVE-2026-30863: parse-server · Improper Authentication

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.3 Critical : upgrade to 9.5.0-alpha.11 or 8.6.10 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.0-alpha.11, 8.6.10
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.5.0-alpha.11 or 8.6.10; parse-community/parse-server to 8.6.10.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • <9.5.0-alpha.11
Fixed in
  • 9.5.0-alpha.11
parse-communityparse-serverAffected
  • <8.6.10
Fixed in
  • 8.6.10
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.10
  • =9.5.0-alpha.11
Fixed in
  • 8.6.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server to version 8.6.10 or later (or 9.5.0-alpha.11 or later for alpha releases) to apply the official patch. Additionally, administrators must ensure that the audience configuration options for Google, Apple, and Facebook authentication adapters are explicitly set to the correct clientId or appIds to enforce audience claim validation. It is recommended to audit existing JWT validation logic and verify that all tokens are properly validated against expected audience claims. Implement monitoring and alerting for unusual authentication patterns or token usage. Consider implementing additional multi-factor authentication layers to reduce risk. Regularly review and update dependencies and authentication configurations to prevent similar issues. Finally, conduct penetration testing focused on authentication bypass scenarios to validate the effectiveness of mitigations.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.10 and 9.5.0-alpha.11, the Google, Apple, and Facebook authentication adapters use JWT verification to validate identity tokens. When the adapter's audience configuration option is not set (clientId for Google/Apple, appIds for Facebook), JWT verification silently skips audience claim validation. This allows an attacker to use a validly signed JWT issued for a different application to authenticate as any user on the target Parse Server. This issue has been patched in versions 8.6.10 and 9.5.0-alpha.11.

References

Community reviews

Loading reviews…