Skip to main content
VulnerabilityPublished

CVE-2026-30868: opnsense core · Cross-Site Request Forgery (CSRF)

Affects opnsense coreSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 26.1.4 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.1.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade core and opnsense/core to 26.1.4.

Affected software

ProductAffectedFixed in
opnsensecoreAffected
  • <26.1.4
Fixed in
  • 26.1.4
GitHubopnsense/corepkg:github/opnsense/coreOther threatsAffected
  • <26.1.4
Fixed in
  • 26.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade all OPNsense core installations to version 26.1.4 or later, where this CSRF vulnerability is patched.
  2. Review and restrict user access to the OPNsense web interface, enforcing the principle of least privilege to minimize the number of authenticated users exposed to potential CSRF attacks.
  3. Implement network segmentation and firewall rules to limit administrative interface access to trusted networks or VPNs only, reducing exposure to malicious websites.
  4. Educate users about the risks of visiting untrusted websites while authenticated to critical infrastructure management portals.
  5. Consider deploying web application firewalls (WAFs) or reverse proxies that can detect and block suspicious HTTP GET requests that attempt state changes.
  6. Monitor OPNsense logs for unusual configuration changes or service reloads that may indicate exploitation attempts.
  7. If upgrading immediately is not feasible, temporarily disable or restrict access to vulnerable API endpoints or enforce additional CSRF protections via custom rules or plugins.

Description

OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.4, multiple OPNsense MVC API endpoints perform state‑changing operations but are accessible via HTTP GET requests without CSRF protection. The framework CSRF validation in ApiControllerBase only applies to POST/PUT/DELETE methods, allowing authenticated GET requests to bypass CSRF verification. As a result, a malicious website can trigger privileged backend actions when visited by an authenticated user, causing unintended service reloads and configuration changes through configd. This results in an authenticated Cross‑Site Request Forgery vulnerability allowing unauthorized system state changes. This vulnerability is fixed in 26.1.4.

References

Community reviews

Loading reviews…