Skip to main content
VulnerabilityPublished

CVE-2026-30949: parse-server · Improper Authentication

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.6 High : upgrade to 9.5.2-alpha.5 or 8.6.18 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.2-alpha.5, 8.6.18
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.5.2-alpha.5 or 8.6.18; parse-server to 8.6.18.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.5.2-alpha.5
Fixed in
  • 9.5.2-alpha.5
parse-communityparse-serverAffected
  • <8.6.18
Fixed in
  • 8.6.18
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • <8.6.18
Fixed in
  • 8.6.18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server to versions 9.5.2-alpha.5 or later, or 8.6.18 or later, where the Keycloak adapter properly validates the 'azp' claim. Until upgrading, administrators should consider restricting Keycloak realms to single-client configurations to reduce risk or implement additional token validation logic at the application layer to verify the 'azp' claim against the expected client-id. Monitoring and logging authentication attempts for anomalies related to token usage across clients can help detect exploitation attempts. Additionally, ensure that access tokens are securely stored and transmitted to prevent token theft. Review Keycloak client configurations to minimize token sharing and enforce strict client isolation. Regularly audit and rotate tokens and credentials to limit the window of exposure. Finally, educate developers and administrators about the risks of multi-client realms without proper token validation.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.5 and 8.6.18, the Keycloak authentication adapter does not validate the azp (authorized party) claim of Keycloak access tokens against the configured client-id. A valid access token issued by the same Keycloak realm for a different client application can be used to authenticate as any user on the Parse Server that uses the Keycloak adapter. This enables cross-application account takeover in multi-client Keycloak realms. All Parse Server deployments that use the Keycloak authentication adapter with a Keycloak realm that has multiple client applications are affected. This vulnerability is fixed in 9.5.2-alpha.5 and 8.6.18.

References

Community reviews

Loading reviews…