Skip to main content
VulnerabilityPublished

CVE-2026-30962: parse-server · Improper Access Control

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High : upgrade to 9.5.2-alpha.6 or 8.6.19 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.2-alpha.6, 8.6.19
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.5.2-alpha.6 or 8.6.19; parse-server to 8.6.19.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.5.2-alpha.6
Fixed in
  • 9.5.2-alpha.6
parse-communityparse-serverAffected
  • <8.6.19
Fixed in
  • 8.6.19
npmparse-serverpkg:npm/parse-serverOther threatsAffected
  • <8.6.19
Fixed in
  • 8.6.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade parse-server to version 9.5.2-alpha.6 or 8.6.19 or later, where the vulnerability is fixed. Until upgrades can be applied, organizations should implement strict query validation and sanitization on the application side to detect and block nested logical operators targeting protected fields. Additionally, review and minimize the number of protected fields and sensitive data stored in parse-server to reduce exposure. Implement robust authentication and monitoring to detect unusual query patterns indicative of exploitation attempts. Employ network segmentation and least privilege principles to limit access to parse-server instances. Conduct regular security audits and penetration testing focusing on query injection and access control bypass scenarios. Finally, educate developers and administrators about this vulnerability and ensure timely patch management processes are in place.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.

References

Community reviews

Loading reviews…