CVE-2026-30965: parse-server · Incorrect Authorization
Affects parse-serverSource CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 9.9 Critical : upgrade to 9.5.2-alpha.8 or 8.6.21 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.3% chance of exploitation in 30 days – higher than 71% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.5.2-alpha.8, 8.6.21
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Mar 2026
Detectable: evidence found.
nuclei template: Parse Server < 8.6.21 / 9.x < 9.5.2 - Session Token Exfiltration
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.5.2-alpha.8 or 8.6.21; parse-community/parse-server to 8.6.21.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-30965, organizations should immediately upgrade parse-server to versions 9.5.2-alpha.8 or later, or 8.6.21 or later, where the vulnerability is fixed. Until upgrades can be applied, restrict access to parse-server endpoints by implementing network-level controls such as IP whitelisting and firewall rules to limit exposure. Review and tighten Class-Level Permissions (CLPs) to minimize the ability of users or unauthenticated actors to create or update objects with relation fields. Implement monitoring and alerting for unusual query patterns involving redirectClassNameForKey parameters or unexpected object relation modifications. Employ session token management best practices, including short token lifetimes and revocation mechanisms, to reduce the window of opportunity for attackers. Conduct thorough security assessments and penetration testing focused on authorization controls in parse-server deployments. Finally, maintain an up-to-date inventory of parse-server instances and ensure all development and production environments are patched promptly.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.8 and 8.6.21, a vulnerability in Parse Server's query handling allows an authenticated or unauthenticated attacker to exfiltrate session tokens of other users by exploiting the redirectClassNameForKey query parameter. Exfiltrated session tokens can be used to take over user accounts. The vulnerability requires the attacker to be able to create or update an object with a new relation field, which depends on the Class-Level Permissions of at least one class. This vulnerability is fixed in 9.5.2-alpha.8 and 8.6.21.