CVE-2026-31856: parse-server · SQL Injection
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 9.6.0-alpha.3 or 8.6.29 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.6.0-alpha.3, 8.6.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.6.0-alpha.3 or 8.6.29; parse-server to 8.6.29.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-serverpkg:npm/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should urgently upgrade parse-server deployments to versions 9.6.0-alpha.3 or later, or 8.6.29 or later, where the vulnerability is patched. Until upgrades are applied, restrict access to the Parse Server REST API to trusted networks and authenticated users only, employing network segmentation and firewall rules to limit exposure. Implement Web Application Firewalls (WAFs) with custom rules to detect and block suspicious SQL injection patterns targeting Increment operations with dot notation. Review and audit all API endpoints that accept write requests to ensure they do not allow untrusted input to be directly used in database queries. Employ runtime application self-protection (RASP) tools if available to monitor and block injection attempts dynamically. Additionally, conduct thorough security testing and code reviews focusing on database query construction and input validation. Monitoring database logs for anomalous queries and unusual access patterns can help detect exploitation attempts early. Finally, educate developers on secure coding practices, emphasizing parameterized queries and input sanitization to prevent similar vulnerabilities.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. A SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The amount value is interpolated directly into the SQL query without parameterization or type validation. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL subqueries to read any data from the database, bypassing CLPs and ACLs. MongoDB deployments are not affected. This vulnerability is fixed in 9.6.0-alpha.3 and 8.6.29.