Skip to main content
VulnerabilityPublished Updated

CVE-2026-31887: shopware core · Incorrect Authorization

Affects shopware coreSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.9 High : upgrade to 6.7.8.1 or 6.6.10.15 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.7.8.1, 6.6.10.15
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade core and platform to 6.7.8.1 or 6.6.10.15; shopware/core to 6.6.10.15.

Affected software

ProductAffectedFixed in
shopwarecoreAffected
  • >=6.7.0.0 <6.7.8.1
Fixed in
  • 6.7.8.1
shopwarecoreAffected
  • <6.6.10.15
Fixed in
  • 6.6.10.15
shopwareplatformAffected
  • >=6.7.0.0 <6.7.8.1
Fixed in
  • 6.7.8.1
shopwareplatformAffected
  • <6.6.10.15
Fixed in
  • 6.6.10.15
GitHubshopware/corepkg:github/shopware/coreOther threatsAffected
  • <6.6.10.15
Fixed in
  • 6.6.10.15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations using Shopware versions prior to 6.7.8.1 or 6.6.10.15 should immediately upgrade to the patched versions to remediate this vulnerability. In addition to patching, administrators should audit access logs for unusual or unauthorized access patterns to the store-api.order endpoint. Implementing Web Application Firewalls (WAFs) with rules to detect and block anomalous API requests targeting order retrieval endpoints can provide temporary protection. Restricting API access to authenticated users where feasible and enforcing strict input validation on filter parameters can reduce exploitation risk. Regularly reviewing and hardening access control policies within Shopware configurations is recommended. Organizations should also ensure compliance with data protection regulations by promptly addressing any data exposure incidents and notifying affected customers as required.

Description

CVE-2026-31887 is a high-severity authorization vulnerability in Shopware core versions prior to 6.7.8.1 and 6.6.10.15. It allows unauthenticated users to access orders belonging to other customers via insufficient filtering on the store-api.order endpoint, specifically related to deepLinkCode support. The flaw stems from an incorrect authorization check (CWE-863) that fails to properly restrict access to order data.

References

Community reviews

Loading reviews…