CVE-2026-31901: parse-server · Observable Response Discrepancy
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 9.6.0-alpha.8 or 8.6.34 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.6.0-alpha.8, 8.6.34
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.6.0-alpha.8 or 8.6.34; parse-community/parse-server to 8.6.34.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, organizations should upgrade parse-server to version 8.6.34 or later, or 9.6.0-alpha.8 or later, where the issue is fixed by normalizing error responses to prevent user enumeration. If immediate upgrade is not feasible, administrators can implement custom middleware or API gateway rules to standardize responses from the /verificationEmailRequest endpoint, ensuring identical error messages regardless of email existence or verification status. Additionally, rate limiting and IP reputation filtering can reduce the risk of automated enumeration attempts. Monitoring logs for unusual patterns of verification requests can help detect exploitation attempts. Educating users about phishing risks and enforcing strong authentication mechanisms (e.g., multi-factor authentication) can mitigate downstream risks from enumerated accounts. Finally, reviewing and minimizing exposed information in API responses is a best practice to prevent similar vulnerabilities.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.34 and 9.6.0, the email verification endpoint (/verificationEmailRequest) returns distinct error responses depending on whether an email address belongs to an existing user, is already verified, or does not exist. An attacker can send requests with different email addresses and observe the error codes to determine which email addresses are registered in the application. This is a user enumeration vulnerability that affects any Parse Server deployment with email verification enabled (verifyUserEmails: true). This vulnerability is fixed in 8.6.34 and 9.6.0.