Skip to main content
VulnerabilityPublished Updated

CVE-2026-32141: WebReflection flatted · Uncontrolled Recursion

Affects WebReflection flattedSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 3.4.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade WebReflection flatted to 3.4.0.

Affected software

ProductAffectedFixed in
WebReflectionflattedAffected
  • <3.4.0
Fixed in
  • 3.4.0
npmflattedpkg:npm/flattedOther threatsAffected
  • <3.4.0
Fixed in
  • 3.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in flatted version 3.4.0. Users should upgrade to version 3.4.0 or later to remediate this vulnerability. The Red Hat advisory notes that no alternative mitigations meet their criteria for ease of use and applicability, so upgrading is the recommended action.

Description

flatted is a circular JSON parser. Prior to 3.4.0, flatted's parse() function uses a recursive revive() phase to resolve circular references in deserialized JSON. When given a crafted payload with deeply nested or self-referential $ indices, the recursion depth is unbounded, causing a stack overflow that crashes the Node.js process. This vulnerability is fixed in 3.4.0.

References

Community reviews

Loading reviews…