Skip to main content
VulnerabilityPublished

CVE-2026-32234: parse-server · SQL Injection

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.1 Medium : upgrade to 9.6.0-alpha.10 or 8.6.36 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.10, 8.6.36
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.10 or 8.6.36; parse-community/parse-server to 8.6.36.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.10
Fixed in
  • 9.6.0-alpha.10
parse-communityparse-serverAffected
  • <8.6.36
Fixed in
  • 8.6.36
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.36
Fixed in
  • 8.6.36

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server to version 9.6.0-alpha.10 or later, or 8.6.36 or later, depending on their version branch. As a best practice, restrict access to the master key to the minimum necessary personnel and systems, and rotate the master key if compromise is suspected. Implement strict monitoring and alerting on master key usage and database query anomalies. Consider deploying Web Application Firewalls (WAFs) with custom rules to detect unusual query patterns targeting $regex operators. Conduct regular security audits of parse-server configurations and PostgreSQL query logs to detect potential exploitation attempts. Additionally, evaluate the necessity of using PostgreSQL as the backend if risk tolerance is low, or consider additional database-level security controls such as role-based access controls and query parameterization enforcement.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0 and 8.6.36, an attacker with access to the master key can inject malicious SQL via crafted field names used in query constraints when Parse Server is configured with PostgreSQL as the database. The field name in a $regex query operator is passed to PostgreSQL using unparameterized string interpolation, allowing the attacker to manipulate the SQL query. While the master key controls what can be done through the Parse Server abstraction layer, this SQL injection bypasses Parse Server entirely and operates at the database level. This vulnerability only affects Parse Server deployments using PostgreSQL. This vulnerability is fixed in 9.6.0 and 8.6.36.

References

Community reviews

Loading reviews…