CVE-2026-32730: apostrophecms apostrophe · Improper Authentication
Affects apostrophecms apostropheSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 4.28.0 soon.
Data as of 31 Oct 2026, 08:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.28.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 18 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade apostrophe and apostrophecms/apostrophe to 4.28.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| apostrophecmsapostrophe | Affected
| Fixed in
|
npmapostrophecms/apostrophepkg:npm/apostrophecms/apostropheOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediately upgrade all ApostropheCMS installations to version 4.28.0 or later, which contains the fix for this vulnerability.
- Until patching is complete, implement network-level access controls to restrict access to the CMS administration interfaces to trusted IP addresses or VPNs.
- Review and audit authentication logs for any suspicious bearer token usage or login attempts that bypass MFA.
- If feasible, temporarily disable bearer token authentication or enforce additional verification steps outside the vulnerable middleware.
- Conduct a thorough security review of custom login flows, especially those that implement afterPasswordVerified hooks, to ensure MFA enforcement is robust.
- Employ Web Application Firewalls (WAFs) with custom rules to detect and block anomalous authentication requests targeting the vulnerable endpoints.
- Educate administrators and developers about the importance of applying security patches promptly and monitoring for unusual authentication patterns.
- Consider implementing additional compensating controls such as IP reputation checks or anomaly detection on authentication events until the patch is deployed.
Description
CVE-2026-32730 is a high-severity authentication bypass vulnerability in ApostropheCMS versions prior to 4.28.0. The flaw exists in the bearer token authentication middleware where an incorrect MongoDB query allows tokens that have passed password verification but not multi-factor authentication (MFA) to be accepted as fully authenticated. This bypasses MFA protections for any deployment using the login-totp module or custom post-password verification requirements. Exploitation requires no user interaction and can be performed remotely over the network. The vulnerability impacts confidentiality, integrity, and availability by allowing unauthorized access to protected resources. No known exploits are currently in the wild, but the issue is critical for organizations relying on ApostropheCMS with MFA enabled. Upgrading to version 4.28.