CVE-2026-32942: pjsip pjproject · Use After Free
Affects pjsip pjprojectSource CVE Database V5
Not known to be exploited · CVSS 8.0 High : upgrade to 2.17 soon.
Data as of 1 Nov 2026, 11:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.17
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 20 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade pjproject and pjsip/pjproject to 2.17.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pjsippjproject | Affected
| Fixed in
|
GitHubpjsip/pjprojectpkg:github/pjsip/pjprojectOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should promptly upgrade all pjproject deployments to version 2.17 or later, where the vulnerability is fixed. For environments where immediate upgrading is not feasible, applying temporary mitigations such as isolating vulnerable services behind firewalls, restricting network access to trusted hosts, and monitoring for unusual ICE session activity can reduce risk. Implementing runtime protections like memory safety tools (e.g., AddressSanitizer) during development and testing can help detect similar issues. Additionally, organizations should audit their communication infrastructure to identify all instances of pjproject usage, including embedded devices and third-party applications. Regularly updating and patching multimedia communication libraries, combined with network segmentation and intrusion detection systems tuned for VoIP anomalies, will further enhance security posture against exploitation attempts.
Description
CVE-2026-32942 is a high-severity use-after-free vulnerability in the pjsip pjproject multimedia communication library, affecting versions prior to 2.17. The flaw arises from race conditions during ICE session destruction and callback execution, leading to heap memory corruption. Exploitation requires no authentication or user interaction and can result in high confidentiality and integrity impacts, such as remote code execution or denial of service. The vulnerability has been fixed in version 2.17. Organizations using vulnerable versions of pjproject in VoIP or multimedia applications should urgently update to mitigate risks. No known exploits are currently reported in the wild. Countries with significant pjproject deployment and strategic VoIP infrastructure are at higher risk.