Skip to main content
VulnerabilityPublished Updated

CVE-2026-33151: socketio socket.io · Improper Input Validation

Affects socketio socket.ioSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High · fixed in 4.2.6 : patch socketio socket.io soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.6, 3.4.4, 3.3.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade socket.io to 4.2.6, 3.4.4 or 3.3.5; socket.io/socket.io to 3.3.5.

Affected software

ProductAffectedFixed in
socketiosocket.ioAffected
  • >=4.0.0 <4.2.6
Fixed in
  • 4.2.6
socketiosocket.ioAffected
  • >=3.4.0 <3.4.4
Fixed in
  • 3.4.4
socketiosocket.ioAffected
  • <3.3.5
Fixed in
  • 3.3.5
npmsocket.io/socket.iopkg:npm/socket.io/socket.ioOther threatsAffected
  • <3.3.5
Fixed in
  • 3.3.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Socket.IO to version 3.3.5, 3.4.4, or 4.2.6 or later, where this vulnerability is patched. No other mitigation or temporary workaround is indicated by the vendor advisory.

Description

Socket.IO versions prior to 3.3.5, 3.4.4, and 4.2.6 contain an improper input validation vulnerability. A specially crafted packet can cause the server to buffer a large number of binary attachments, potentially exhausting server memory. This vulnerability has been patched in the specified versions.

References

Community reviews

Loading reviews…