CVE-2026-33157: craftcms cms · Unsafe Reflection
Affects craftcms cmsSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 5.9.13 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 65% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.13
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade cms and craftcms/cms to 5.9.13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscms | Affected
| Fixed in
|
GitHubcraftcms/cmspkg:github/craftcms/cmsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, organizations should immediately upgrade Craft CMS to version 5.9.13 or later, where the issue is patched. Prior to upgrading, restrict control panel access to trusted users only and enforce strong authentication mechanisms such as multi-factor authentication (MFA) to reduce the risk of credential compromise. Conduct thorough audits of user accounts and permissions to ensure no unauthorized access is possible. Monitor logs for unusual activity related to the ElementIndexesController or unexpected behavior injection attempts. If upgrading is not immediately feasible, consider implementing web application firewall (WAF) rules to detect and block suspicious payloads targeting the fieldLayouts parameter, although this is a temporary measure. Educate administrators about the risks of unsafe reflection and the importance of applying vendor patches promptly. Finally, review and harden CMS configurations to minimize exposure of sensitive endpoints.
Description
CVE-2026-33157 is a high-severity Remote Code Execution (RCE) vulnerability in Craft CMS versions 5.6.0 through 5.9.12. It arises from unsafe reflection due to unsanitized user input in the fieldLayouts parameter of ElementIndexesController::actionFilterHud(), allowing authenticated users with control panel access to execute arbitrary code. This vulnerability bypasses previous fixes intended to prevent Yii2 behavior/event injection attacks. The flaw has been patched in version 5.9.13.