Skip to main content
VulnerabilityPublished Updated

CVE-2026-33209: avo · Cross-site Scripting

Affects avoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.30.3 when convenient.

Data as of 2 Nov 2026, 10:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.30.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade avo to 3.30.3.

Affected software

ProductAffectedFixed in
avo-hqavoAffected
  • <3.30.3
Fixed in
  • 3.30.3
RubyGemsavopkg:gem/avoOther threatsAffected
  • <3.30.3
Fixed in
  • 3.30.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should upgrade avo to version 3.30.3 or later, where this vulnerability is patched. Until upgrading, implement strict input validation and output encoding on the 'return_to' parameter to prevent injection of malicious scripts. Employ Content Security Policy (CSP) headers to restrict execution of unauthorized scripts in the admin interface. Educate users, especially administrators, to be cautious about clicking untrusted links. Monitor web server logs for suspicious requests containing unusual 'return_to' parameter values. Consider implementing web application firewalls (WAFs) with rules to detect and block reflected XSS attempts targeting the avo interface. Regularly review and update dependencies to minimize exposure to known vulnerabilities.

Description

Avo is a framework to create admin panels for Ruby on Rails apps. Prior to version 3.30.3, a reflected cross-site scripting (XSS) vulnerability exists in the return_to query parameter used in the avo interface. An attacker can craft a malicious URL that injects arbitrary JavaScript, which is executed when he clicks a dynamically generated navigation button. This issue has been patched in version 3.30.3.

References

Community reviews

Loading reviews…