Skip to main content
VulnerabilityPublished

CVE-2026-33323: parse-server · Observable Response Discrepancy

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 9.6.0-alpha.40 or 8.6.51 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.40, 8.6.51
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.40 or 8.6.51; parse-community/parse-server to 8.6.51.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.40
Fixed in
  • 9.6.0-alpha.40
parse-communityparse-serverAffected
  • <8.6.51
Fixed in
  • 8.6.51
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.51
Fixed in
  • 8.6.51

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should upgrade parse-server to version 8.6.51 or later, or 9.6.0-alpha.40 or later, where this vulnerability is patched. If immediate upgrade is not feasible, administrators should verify and enforce the emailVerifySuccessOnInvalidEmail configuration is applied consistently across all routes handling email verification resends, including the Pages and legacy PublicAPI routes. Implementing uniform response behavior regardless of username validity or email verification status is critical to prevent enumeration. Additionally, monitoring and rate limiting requests to these endpoints can reduce the risk of automated enumeration attacks. Logging and alerting on suspicious patterns of repeated email verification requests can help detect exploitation attempts. Finally, educating users and administrators about the risks of username enumeration and encouraging strong multi-factor authentication can mitigate downstream risks.

Description

CVE-2026-33323 is a medium-severity vulnerability in parse-community's parse-server prior to versions 8.6.51 and 9.6.0-alpha.40. The issue involves observable response discrepancies in the Pages and legacy PublicAPI routes used for resending email verification links. An unauthenticated attacker can enumerate valid usernames by analyzing different redirect responses depending on whether a username exists and has an unverified email. This vulnerability arises because the emailVerifySuccessOnInvalidEmail configuration, which mitigates enumeration, did not apply to these routes. The flaw allows information disclosure without requiring authentication or user interaction.

References

Community reviews

Loading reviews…