Skip to main content
VulnerabilityPublished Updated

CVE-2026-33414: containers podman · OS Command Injection

Affects containers podmanSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.0 Medium : upgrade to 5.8.2 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
4.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.8.2
CVSS:4.0/AV:L/AC:H/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade podman and containers/podman to 5.8.2.

Affected software

ProductAffectedFixed in
containerspodmanAffected
  • >=4.8.0 <5.8.2
Fixed in
  • 5.8.2
GitHubcontainers/podmanpkg:github/containers/podmanOther threatsAffected
  • >=4.8.0 <5.8.2
Fixed in
  • 5.8.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been fixed in Podman version 5.8.2. Users should upgrade to version 5.8.2 or later to remediate the issue. No additional mitigations are specified by the vendor advisory. Patch status is confirmed by Red Hat advisories linked in the vendor advisory content.

Description

Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.

References

Community reviews

Loading reviews…