Skip to main content
VulnerabilityPublished

CVE-2026-33429: parse-server · Observable Discrepancy

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 9.6.0-alpha.43 or 8.6.54 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6.0-alpha.43, 8.6.54
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.6.0-alpha.43 or 8.6.54; parse-community/parse-server to 8.6.54.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.6.0-alpha.43
Fixed in
  • 9.6.0-alpha.43
parse-communityparse-serverAffected
  • <8.6.54
Fixed in
  • 8.6.54
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.54
Fixed in
  • 8.6.54

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade parse-server to version 8.6.54 or later, or 9.6.0-alpha.43 or later, where the vulnerability is patched. Until upgrades can be applied, organizations should consider disabling LiveQuery subscriptions on protected fields or implementing additional access controls to restrict subscription capabilities to trusted users only. Monitoring LiveQuery event patterns for anomalous subscription behavior may help detect exploitation attempts. Additionally, reviewing application logic to minimize reliance on boolean protected fields that could be inferred via timing analysis can reduce risk. Employing network-level protections such as rate limiting and anomaly detection on LiveQuery endpoints can further mitigate exploitation likelihood. Finally, organizations should audit their parse-server configurations and logs to identify any suspicious subscription activity targeting protected fields.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.54 and 9.6.0, an attacker can subscribe to LiveQuery with a watch parameter targeting a protected field. Although the protected field value is properly stripped from event payloads, the presence or absence of update events reveals whether the protected field changed, creating a binary oracle. For boolean protected fields, the timing of change events is equivalent to knowing the field value. This issue has been patched in versions 8.6.54 and 9.6.0

References

Community reviews

Loading reviews…