CVE-2026-33539: parse-server · SQL Injection
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 9.6.0-alpha.53 or 8.6.59 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.6.0-alpha.53, 8.6.59
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.6.0-alpha.53 or 8.6.59; parse-community/parse-server to 8.6.59.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, organizations should immediately upgrade parse-server to version 8.6.59 or later, or 9.6.0-alpha.53 or later, where the issue is patched. Additionally, strict protection and rotation of master keys are critical to prevent unauthorized access. Implementing robust access controls and monitoring for unusual master key usage can help detect potential exploitation attempts. Input validation and sanitization should be enforced at the application layer as an additional defense-in-depth measure. Organizations should also audit their PostgreSQL logs for suspicious queries that may indicate exploitation attempts. Where possible, consider limiting the privileges of the database user account used by parse-server to reduce the impact of any injection. Employ network segmentation and firewall rules to restrict database access only to trusted application servers. Finally, maintain an incident response plan to quickly address any detected compromise involving master keys or database access.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.59 and 9.6.0-alpha.53, an attacker with master key access can execute arbitrary SQL statements on the PostgreSQL database by injecting SQL metacharacters into field name parameters of the aggregate $group pipeline stage or the distinct operation. This allows privilege escalation from Parse Server application-level administrator to PostgreSQL database-level access. Only Parse Server deployments using PostgreSQL are affected. MongoDB deployments are not affected. This issue has been patched in versions 8.6.59 and 9.6.0-alpha.53.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-p2w6-rmh7-w8q3 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10272 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10273 (opens in a new tab)
- github.com/parse-community/parse-server/commit/03249f9bf5b8783c8b848f84dab791ff0b761b8c (opens in a new tab)
- github.com/parse-community/parse-server/commit/bdddab5f8b61a40cb8fc62dd895887bdd2f3838e (opens in a new tab)