Skip to main content
VulnerabilityPublished

CVE-2026-33626: InternLM lmdeploy · Server-Side Request Forgery (SSRF)

Affects InternLM lmdeploySource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · 45% EPSS · CVSS 7.5 High : upgrade to 0.12.3 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
45.2% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.12.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Apr 2026

  2. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade lmdeploy and internlm/lmdeploy to 0.12.3.

Affected software

ProductAffectedFixed in
InternLMlmdeployAffected
  • <0.12.3
Fixed in
  • 0.12.3
GitHubinternlm/lmdeploypkg:github/internlm/lmdeployOther threatsAffected
  • <0.12.3
Fixed in
  • 0.12.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade lmdeploy to version 0.12.3 or later, where this SSRF vulnerability is patched. Since the vendor advisory does not specify any other mitigation or temporary fixes, applying the official update is the recommended remediation. Patch status is not explicitly confirmed in the advisory fields but the description states version 0.12.3 fixes the issue.

Description

LMDeploy versions prior to 0.12.3 contain a Server-Side Request Forgery (SSRF) vulnerability in the vision-language module. The vulnerability arises because the load_image() function fetches arbitrary URLs without validating whether the addresses are internal or private. This flaw allows attackers to potentially access internal network resources, including cloud metadata services. The issue is fixed in version 0.12.3.

References

Community reviews

Loading reviews…