CVE-2026-34356: Apache HTTP Server · Heap-based Buffer Overflow
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 2.4.68 : patch Apache HTTP Server soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HTTP Server | Affected
| Fixed in– |
AI-suggested
Users should upgrade Apache HTTP Server to version 2.4.68 or later, where this vulnerability is fixed. Patch status is confirmed by the vendor's advisory recommending this upgrade. No alternative mitigations or temporary fixes are indicated.
Description
A heap-based buffer overflow vulnerability exists in Apache HTTP Server versions from 2.4.0 through 2.4.67, related to interactions with malicious backend servers and the ProxyPassReverseCookie* directive. This vulnerability can cause a denial of service due to server crashes. The issue is fixed in Apache HTTP Server version 2.4.68.