Skip to main content
VulnerabilityPublished

CVE-2026-34532: parse-server · Incorrect Authorization

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 9.7.0-alpha.11 or 8.6.67 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.7.0-alpha.11, 8.6.67
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.7.0-alpha.11 or 8.6.67; parse-community/parse-server to 8.6.67.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.7.0-alpha.11
Fixed in
  • 9.7.0-alpha.11
parse-communityparse-serverAffected
  • <8.6.67
Fixed in
  • 8.6.67
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.67
Fixed in
  • 8.6.67

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server to version 8.6.67 or later, or to 9.7.0-alpha.11 or later, where the vulnerability is patched. In addition to upgrading, review all Cloud Functions and their validators to ensure they do not rely on vulnerable patterns such as function keyword declarations with plain object or arrow function validators. Implement strict input validation and URL sanitization to detect and block attempts to append prototype chain traversal strings like "prototype.constructor". Employ runtime application self-protection (RASP) or web application firewalls (WAFs) with custom rules to detect anomalous URL patterns targeting Cloud Functions. Conduct thorough security testing, including penetration testing focused on authorization bypass scenarios. Monitor logs for suspicious access patterns to Cloud Functions, especially those invoked without authentication. Finally, maintain an up-to-date inventory of parse-server versions deployed across environments to ensure timely patching.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.67 and 9.7.0-alpha.11, an attacker can bypass Cloud Function validator access controls by appending "prototype.constructor" to the function name in the URL. When a Cloud Function handler is declared using the function keyword and its validator is a plain object or arrow function, the trigger store traversal resolves the handler through its own prototype chain while the validator store fails to mirror this traversal, causing all access control enforcement to be skipped. This allows unauthenticated callers to invoke Cloud Functions that are meant to be protected by validators such as requireUser, requireMaster, or custom validation logic. This issue has been patched in versions 8.6.67 and 9.7.0-alpha.11.

References

Community reviews

Loading reviews…