Skip to main content
VulnerabilityPublished

CVE-2026-34573: parse-server · Inefficient Algorithmic Complexity

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 9.7.0-alpha.12 or 8.6.68 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.7.0-alpha.12, 8.6.68
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.7.0-alpha.12 or 8.6.68; parse-community/parse-server to 8.6.68.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.7.0-alpha.12
Fixed in
  • 9.7.0-alpha.12
parse-communityparse-serverAffected
  • <8.6.68
Fixed in
  • 8.6.68
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.68
Fixed in
  • 8.6.68

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade parse-server to version 8.6.68 or later, or 9.7.0-alpha.12 or later, where the vulnerability has been patched. If upgrading is not immediately feasible, consider disabling the requestComplexity.graphQLDepth and requestComplexity.graphQLFields options to prevent the vulnerable complexity validation logic from executing. Implement rate limiting and request throttling on GraphQL endpoints to reduce the impact of potential abuse. Deploy Web Application Firewalls (WAFs) with custom rules to detect and block suspicious GraphQL queries containing excessive fragment spreads or abnormal complexity patterns. Monitor server performance metrics and logs for signs of event loop blocking or unusual query patterns. Additionally, consider isolating parse-server instances behind load balancers that can detect and mitigate DoS conditions. Regularly review and test GraphQL query complexity configurations to balance security and performance without exposing to inefficient algorithmic complexity. Finally, maintain an incident response plan to quickly address any detected DoS attempts.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.68 and 9.7.0-alpha.12, the GraphQL query complexity validator can be exploited to cause a denial-of-service by sending a crafted query with binary fan-out fragment spreads. A single unauthenticated request can block the Node.js event loop for seconds, denying service to all concurrent users. This only affects deployments that have enabled the requestComplexity.graphQLDepth or requestComplexity.graphQLFields configuration options. This issue has been patched in versions 8.6.68 and 9.7.0-alpha.12.

References

Community reviews

Loading reviews…