Skip to main content
VulnerabilityPublished

CVE-2026-34587: getkirby kirby · Template Injection

Affects getkirby kirbySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.6 High : upgrade to 5.4.0 or 4.9.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.0, 4.9.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade kirby to 5.4.0 or 4.9.0; getkirby/kirby to 4.9.0.

Affected software

ProductAffectedFixed in
getkirbykirbyAffected
  • >=5.0.0 <5.4.0
Fixed in
  • 5.4.0
getkirbykirbyAffected
  • <4.9.0
Fixed in
  • 4.9.0
GitHubgetkirby/kirbypkg:github/getkirby/kirbyOther threatsAffected
  • <4.9.0
Fixed in
  • 4.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been patched in Kirby CMS versions 4.9.0 and 5.4.0. Users should upgrade to these or later versions to remediate the issue. Since this is not a cloud service, patching the affected software versions is required. Patch status is confirmed by the vendor advisory embedded in the description. No additional mitigations are indicated.

Description

CVE-2026-34587 is a high-severity vulnerability in the Kirby CMS prior to versions 4.9.0 and 5.4.0. It involves improper neutralization of special elements in the template engine related to user permissions. Specifically, authenticated users with the pages.create permission could bypass the intended editorial workflow by creating published pages directly via the REST API, overriding the isDraft flag. This bypass occurs because the changeStatus permission was not enforced on page creation through the API. The issue has been fixed in Kirby versions 4.

References

Community reviews

Loading reviews…