CVE-2026-34784: parse-server · Improper Authorization
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 9.7.1-alpha.1 or 8.6.71 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.7.1-alpha.1, 8.6.71
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.7.1-alpha.1 or 8.6.71; parse-community/parse-server to 8.6.71.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The primary mitigation is to upgrade parse-server to version 8.6.71 or later, or 9.7.1-alpha.1 or later, where the authorization bypass has been patched. Until upgrades can be applied, organizations should consider restricting access to parse-server endpoints through network-level controls such as IP whitelisting, VPNs, or firewall rules to limit exposure. Implementing strict authentication and authorization at the application gateway or reverse proxy can provide an additional layer of defense. Monitoring HTTP traffic for suspicious Range requests targeting file downloads may help detect exploitation attempts. Reviewing and hardening storage adapter configurations to disable streaming if not required can reduce risk. Finally, conducting security audits and penetration tests focused on file access controls in parse-server deployments is recommended to identify any residual weaknesses.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.71 and 9.7.1-alpha.1, file downloads via HTTP Range requests bypass the afterFind(Parse.File) trigger and its validators on storage adapters that support streaming (e.g.the default GridFS adapter). This allows access to files that should be protected by afterFind trigger authorization logic or built-in validators such as requireUser. This issue has been patched in versions 8.6.71 and 9.7.1-alpha.1.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-hpm8-9qx6-jvwv (opens in a new tab)
- github.com/parse-community/parse-server/pull/10361 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10362 (opens in a new tab)
- github.com/parse-community/parse-server/commit/053109b3ee71815bc39ed84116c108ff9edbf337 (opens in a new tab)
- github.com/parse-community/parse-server/commit/a0b0c69fc44f87f80d793d257344e7dcbf676e22 (opens in a new tab)