Skip to main content
VulnerabilityPublished

CVE-2026-35164: Ajax30 BraveCMS-2.0 · Unrestricted File Upload

Affects Ajax30 BraveCMS-2.0Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 2.0.6 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade BraveCMS-2.0 and ajax30/BraveCMS-2.0 to 2.0.6.

Affected software

ProductAffectedFixed in
Ajax30BraveCMS-2.0Affected
  • <2.0.6
Fixed in
  • 2.0.6
GitHubajax30/BraveCMS-2.0pkg:github/ajax30/BraveCMS-2.0Other threatsAffected
  • <2.0.6
Fixed in
  • 2.0.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade BraveCMS to version 2.0.6 or later, where this vulnerability has been fixed. Since the vulnerability is resolved in this version, no additional mitigation steps are required beyond applying the official update. Patch status is confirmed fixed in version 2.0.6.

Description

Brave CMS versions prior to 2.0.6 contain an unrestricted file upload vulnerability in the CKEditor upload functionality. The vulnerability exists because the ckupload method does not properly validate file types, allowing authenticated users to upload executable PHP scripts. This can lead to remote code execution on the affected system. The vulnerability is tracked as CVE-2026-35164 and has a high severity rating with a CVSS score of 8.8. A fix for this issue was introduced in version 2.0.6.

References

Community reviews

Loading reviews…